Jump to content

swiftkit not working?


Recommended Posts

Mine won't even open .I have "Run time error 13 type mismatch"


I've looked on sk site for help and it said to delete the file swiftirc.ocx and let it update. I did that and it's still not working.


1. Close SwiftKit.

2. CTRL + ALT + Delete and end task any SwiftKit.exe processes.

3. Go to your SwiftKit directory(default is C:\Program Files\SwiftKit or you can right click the SwiftKit shortcut > properties > find target or open file location)

4. Delete the file swiftirc.ocx

5. Reopen SwiftKit and let it update.


Still get the error



Link to comment
Share on other sites

Do you have full admin access?


if so after you delete swiftirc.ocx right click swiftkit.exe not swiftkit-rs.exe and go run as admin. This in theory should make sure that the launcher can write to the folder.


if that fails try running the installer again (don't bother uninstalling) this should fix and bogus registry entries


if that then fail try going


Start > Run and type: regsvr32 "c:/program files/swiftkit/swiftirc.ocx"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...